detail.php
OW2 Forge: Detail: 303643 Bug on XQuery sequence construction

Advanced - Powered by Google


   
Log In
New Account
  
 
Home
My Page
Project Tree
Project Openings
XQuare
          
 
 
Summary
Forums
Tracker
Lists
Tasks
Docs
News
CVS
Files
SVN
                    
 

Tracker: Bugs

Submit New | Browse | Admin | ExportToXml

[ #303643 ] Bug on XQuery sequence construction

Date:
2005-06-12 08:45
Priority:
5
Submitted By:
Alan Tam (at2000)
Assigned To:
Nobody (None)
Category:
bridge
State:
Open
Summary:
Bug on XQuery sequence construction

Detailed description:
Using the W3C test database on mysql. Reproducible on both 1.1.0 and cvs-head. <Result> { for $item2 in ( for $item in collection("items")/items return $item, for $item in collection("items")/items[itemno='1008'] return $item ) return $item2 } </Result> Only the itemno='1008' part is returned. The first part is missing.

Add A Comment:

Please login

Followup

Message
Date: 2005-06-12 08:55
Sender: at2000
Logged In: YES 
user_id=2500

In this query, I expect it to return n+1 items (where there
are n in the database), but it turns out to have missed out
the hand-coded item.

<Result>
{
  for $item2 in (
    for $item in collection("items")/items
    return $item,
    <item>
      <itemno>9999</itemno>
      <description>MyOwnDescription</description>
      <offered_by>MyOwnOfferedBy</offered_by>
      <start_date>2004-12-31</start_date>
      <end_date>2005-01-01</end_date>
      <reserved_price>10.000</reserved_price>
    </item>
  )
  return $item2
}
</Result>

Attached Files:

Name Description Download
No Files Currently Attached

Changes:

No Changes Have Been Made to This Item

Copyright © 1999-2008, OW2 Consortium | contact | You have a difficulty, a problem ? Please report an issue using your OW2 forge account credentials