Advanced - Powered by Google

Log In
New Account
My Page
Project Tree
Project Openings

Discussion Forums: Help

Start New Thread Start New Thread | Admin


By: Husain Sutarwala
 RE: Chapter 9 error while compiling [ reply ]  
2004-09-09 04:28
Please refer to <a href=";op=viewtopic&amp;t=53124" target="_new">;op=viewtopic&amp;t=53124</a> for a solution. Also make sure you check <a href=";op=viewtopic&amp;p=3845381#3845381" target="_new">;op=viewtopic&amp;p=3845381#3845381</a> to assure completeness.

By: Robert Mitschke
 RE: Chapter 9 error while compiling [ reply ]  
2004-08-05 08:29
I solved the issue myself. In case someone runs into the same problem here is how I did it: For some reason JBOSS does not find two files which are in JBOSS/server/default/lib. One is jboss-j2ee.jar the other one is javax.servlet.jar. I put these in the JBOSS_CLASSPATH environment variable restarted JBOSS and now it is humming away and working smoothly without any compile errors. Greets Robbi

By: Robert Mitschke
 Chapter 9 error while compiling [ reply ]  
2004-08-04 16:09
Hi, I am trying to complete Chapter 9. When I try to generate the wsdl file I get the following: &lt;wsdl:definitions targetNamespace=&quot;<a href="" target="_new"></a>;&gt; &lt;wsdl:portType name=&quot;StoreAccessLocal&quot;&gt; &lt;/wsdl:portType&gt; - &lt;wsdl:binding name=&quot;MyStoreLoginServiceSoapBinding&quot; type=&quot;impl:StoreAccessLocal&quot;&gt; &lt;wsdlsoap:binding style=&quot;rpc&quot; transport=&quot;<a href=";/" target="_new">;/</a>&gt; &lt;/wsdl:binding&gt; - &lt;wsdl:service name=&quot;StoreAccessLocalService&quot;&gt; - &lt;wsdl:port binding=&quot;impl:MyStoreLoginServiceSoapBinding&quot; name=&quot;MyStoreLoginService&quot;&gt; &lt;wsdlsoap:address location=&quot;<a href=";/" target="_new">;/</a>&gt; &lt;/wsdl:port&gt; &lt;/wsdl:service&gt; &lt;/wsdl:definitions&gt; Which is different from what the Tutorial says I should get. I also do not see the method listed on the <a href="" target="_new"></a> page. Additionally if I click on Call a local endpoint on the main Axis page I get the following error in my JBoss Console: 16:02:20,211 INFO [Server] JBoss (MX MicroKernel) [3.2.3 (build: CVSTag=JBoss_3_2_3 date=200311301445)] Started in 26s:68ms 16:06:03,973 ERROR [JWSHandler] Exception: AxisFault faultCode: {<a href="}Server.compileError" target="_new">}Server.compileError</a> faultSubcode: faultString: Error while compiling: D:\Roche\jboss-3.2.3\server\default\deploy\webapps\axis.war\WEB-INF\jwsClasses\EchoHeaders.j ava faultActor: faultNode: faultDetail: {}Errors: Error compiling D:\Roche\jboss-3.2.3\server\default\deploy\webapps\axis.war\WEB-INF\jwsClasses\ Line 0, column 0: could not parse error message: Note: has been deprecated. D:\Roche\jboss-3.2.3\server\default\deploy\webapps\axis.war\WEB-INF\jwsClasses\ Class javax.servlet.http.HttpS ervletRequest not found in import. import javax.servlet.http.HttpServletRequest; ^ Line 0, column 0: 1 error, 1 warning Error while compiling: D:\Roche\jboss-3.2.3\server\default\deploy\webapps\axis.war\WEB-INF\jwsClasses\ at org.apache.axis.handlers.JWSHandler.setupService( at org.apache.axis.handlers.JWSHandler.invoke( at org.apache.axis.strategies.InvocationStrategy.visit( at org.apache.axis.SimpleChain.doVisiting( at org.apache.axis.SimpleChain.invoke( at org.apache.axis.server.AxisServer.invoke( at org.apache.axis.transport.http.AxisServlet.invokeEndpointFromGet( at org.apache.axis.transport.http.AxisServlet.processMethodRequest( at org.apache.axis.transport.http.AxisServlet.doGet( at javax.servlet.http.HttpServlet.service( I am using Eclipse 3.0 JBoss 3.2.3 and Axis 1.1 Does anyone have an idea on what I am doing wrong? I have already tried to search google for a hint but all I found has not led to success yet. Would be very grateful if someone could point me into the right direction. Greets Robbi


Copyright © 1999-2008, OW2 Consortium | contact | PS: You have a difficulty, a problem ? Please report an issue using your main OW2 account credentials